LUVTruck.com

phpBBV3 Message Board
It is currently Wed Oct 20, 2021 7:26 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Fuel pump issues?
PostPosted: Tue Jul 16, 2019 9:07 pm 
Offline
Newbie

Joined: Sat May 04, 2019 8:41 am
Posts: 1
Hey guys, I have a 79 luv 4x4 and I recently replaced the fuel pump, about two months later I had to replace it again. It seems to be running fine, but the pump is getting pretty hot, I’m not sure how to fix it, or if I’m using the rite pump, I’m also wondering if my gas tank isn’t venting properly
If anybody can give me some tips that would be awesome, thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: Fuel pump issues?
PostPosted: Wed Jul 17, 2019 11:00 am 
Offline
Addicted to LUV

Joined: Sun Jun 06, 2004 11:48 pm
Posts: 6321
Location: Whittier, (So). Cal.
Are you sure it's getting a good ground? Sand/scrape the mounting area or the ground wire connection if it has one.
The pump on mine does get pretty warm.
Are you sure the fuel is getting from the tank to the pump well? Could have a problem that is starving the pump and burning it out.... or a blockage on the pressure side also.

_________________
OK, I'm over it. Where's the beer? 8)


Top
 Profile  
Reply with quote  
 Post subject: Re: Fuel pump issues?
PostPosted: Wed Jul 17, 2019 7:33 pm 
Offline
Addicted to LUV
User avatar

Joined: Sat May 11, 2002 3:47 pm
Posts: 3461
Location: Sand Bernardino, CA
Could be the Ethanol they put in gasoline now?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group