LUVTruck.com

phpBBV3 Message Board
It is currently Fri Apr 20, 2018 12:57 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Fri Mar 17, 2017 1:10 pm 
Offline
Junior Member

Joined: Thu Oct 06, 2016 9:06 pm
Posts: 7
Bought a weber to replace my busted hitachi. got it installed but as i already knew the kit supplied cable bracket does not work. I saw the vid on bolting the old bracket to it and low and behold my stock bracket is nowhere to be found!. I intentially put it aside knowing i may need it but alas it is MIA.

Im at a stand still now. anyone know of a bracket i can order the will work?? or have a stock one they would part with??? Any help on a solution is greatly appreciated

I did use the stock bellt crank also instead of the weber


Top
 Profile  
Reply with quote  
PostPosted: Fri Mar 17, 2017 7:24 pm 
Offline
Senior Member

Joined: Wed Oct 07, 2015 7:41 am
Posts: 95
Location: Tacoma Washington
Attachment:
image.jpeg
image.jpeg [ 1.48 MiB | Viewed 445 times ]
Can you weld,or know somebody who can? A couple welds and a few holes drilled and you can make a simple,stout,custom bracket to align and hold the cable.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group