LUVTruck.com

phpBBV3 Message Board
It is currently Thu Dec 12, 2019 10:17 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Voltage Regulator Issue
PostPosted: Tue Oct 29, 2019 7:15 pm 
Offline
Member

Joined: Sun Aug 30, 2015 7:27 pm
Posts: 25
Been running into a lot of issues with the LUV lately, previous post was resolved but I need help with this one.

When I start the truck the voltage regulator starts to make a clicking sound inside and the GEN light comes on in sync with these clicks.

What is causing this?

Also, when that is not happening, the GEN will start to flicker when I get up to 50 - 55 MPH in 4th gear, or when I get into higher RPM's with 2nd or 3rd sometimes...

The truck runs mostly fine except for this issue, any ideas?

Thanks as always everyone!

_________________
1978 Chevy LUV
Purchased Aug. 2014
Second owner

2006 Honda Shadow LX
Purchased July 2006
Original owner

"Not all those who wander are lost" - J.R.R. Tolkien
:twisted:


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group