LUVTruck.com

phpBBV3 Message Board
It is currently Sat Nov 18, 2017 8:01 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Broken camshaft
PostPosted: Fri Aug 19, 2016 9:55 pm 
Offline
Senior Member

Joined: Wed May 23, 2007 9:24 pm
Posts: 60
Location: NM
While driving the truck the other day, it started sputtering and back firing. About a half mile from the house, and mostly down hill, was able to nurse it back home. Sounded like it was firing on two cylinders. Checked timing and it was normal. Let it cool off, pulled the spark plugs, the front looked normal, the rear two were wet.

Removed the valve cover and turned the engine over a few times. Only the front four valves were actuating. Rut Row.

I rebuilt this engine several years ago. It is a G200 from a 1985 Impulse.

What would cause the cam to break in half?

Found a stock truck cam on ebay, and installed it. So far so good.

Pics...

Image

Image


Truck is a 1980 4x4. Recently broke a balljoint on a dirt road. Would that cause a broken camshaft?


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group