LUVTruck.com

phpBBV3 Message Board
It is currently Fri Oct 15, 2021 9:16 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jun 20, 2021 10:29 pm 
Offline
Newbie

Joined: Sun Jun 20, 2021 10:19 pm
Posts: 2
    My daughter bought a nice 76 Luv 4 speed.
    Starts and drives great until 4th gear. Bogging down and won’t go faster than 55mph.
    Recently would drive 70+ on the highway.
    1st - 3rd, runs like a champ.
    Shift into fourth and she shutters a bit and just doesn’t accelerate.
    Carb issue?
    Fixed a faulty fuel line not long ago. Maybe not getting enough fuel?
    Would welcome your thoughts.
    Starts and runs great other than this issue.


    Attachments:
    0B6F2921-35F4-49BA-802E-633288AF8B89.jpeg
    0B6F2921-35F4-49BA-802E-633288AF8B89.jpeg [ 815.82 KiB | Viewed 811 times ]
    08B462E4-9D5E-4E02-8162-70CD89A00513.jpeg
    08B462E4-9D5E-4E02-8162-70CD89A00513.jpeg [ 815.82 KiB | Viewed 811 times ]
    Top
     Profile  
    Reply with quote  
    PostPosted: Sat Jul 10, 2021 3:24 pm 
    Offline
    Addicted to LUV

    Joined: Sun Jun 06, 2004 11:48 pm
    Posts: 6321
    Location: Whittier, (So). Cal.
    Some of these trucks had something on them that did something to the carb. when you shifted into 4th I think. Emissions stuff. Maybe look in a manual and see. Nice truck!

    _________________
    OK, I'm over it. Where's the beer? 8)


    Top
     Profile  
    Reply with quote  
    Display posts from previous:  Sort by  
    Post new topic Reply to topic  [ 2 posts ] 

    All times are UTC - 6 hours


    Who is online

    Users browsing this forum: No registered users and 3 guests


    You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum

    Search for:
    Jump to:  
    Powered by phpBB® Forum Software © phpBB Group