LUVTruck.com

phpBBV3 Message Board
It is currently Fri Dec 15, 2017 2:08 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Sep 04, 2017 11:57 am 
Offline
Newbie

Joined: Mon May 09, 2016 10:50 pm
Posts: 1
So a my 14 year old son was helping me Jump my '79 luv. He said "red to positive?" I said "yes" and he hooked the cables up backwards. It was hooked up for a few seconds before I realized what he did.

I pulled the cables off - hooked them up correctly- and it jumped and ran ok. I noticed that when off, now the GEN light is off.

No fuses were blown. I have replaced the voltage regulator. This has done nothing for the GEN light. In addition, A fully charged battery drains in 12 hours when connected (even when I removed the GEN light which is on all the time now regardless.

When it runs it runs fine - but its draining battery all the time. Any idea where to begin with this. I have read a few horror stories about reversing battery cables. Fortunately there isn't a lot of wiring to ruin in a truck of this vintage.

I have driven a few times- with a good battery she runs fine. I just have to unhook the negative cable every time I stop...not a long term solution.


Top
 Profile  
Reply with quote  
PostPosted: Sun Sep 17, 2017 8:28 am 
Offline
da LUV masta
User avatar

Joined: Sun Nov 26, 2006 1:27 pm
Posts: 574
Location: Spokane,Wa.
Have your alternator checked,probably fried some internals.

_________________
"You can't please everyone,so you've got to please yourself"
Image


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group