LUVTruck.com

phpBBV3 Message Board
It is currently Sun Nov 19, 2017 11:50 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 555 posts ]  Go to page Previous  1 ... 24, 25, 26, 27, 28
Author Message
PostPosted: Thu Feb 25, 2016 8:32 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
At one point there was a how to on planetisuzoo that was linked a few times here but the link is dead now. Will see what i can do, definitely don't want it to be rock hard when I lift it

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Fri Feb 26, 2016 2:30 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Getting after it tonight after work. Hopefully i will have it done by the time I head to bed. Gonna do the rear end first since that is a set amount of lift and bring the front up to match.. if I need more out of the front I will bring it up and shackle the back up to match.

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Tue Mar 15, 2016 8:25 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Got a little distracted by my new toy but the tires are still in my list
But this came along and ya know... blew up my old one on a saturday had it sold and replaced by this one on that wednesday

Image

Immediately got this deep in it like i seen to have a habit of doing
Image

Will be back to the truck soon bike will be going back together now that my parts are in

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Sun Mar 27, 2016 5:47 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Been trying to find a way to flare the front just a bit so I can fit the 30s easier without much lift
I just came across this and I'm trying to figure out what was done here.. it almost looks like a stepside wheel well grafted to the fender the shape of the opening looks the same as the bed...

Image

Obviously I don't need to go that extreme but it got me thinking that the rear wheel wells are shaped with a lot more clearance and it wouldn't be real hard to take a sawzall to a junkyard bed and use those to gain some room without any of the cheap flat plastic flares or any of that. I haven't seen a lot of flared fenders that looked right on the truck without matching rears

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 30, 2016 10:07 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Finally getting around to test fitting the 30s tomorrow. Will see how far off I am and go from there

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Fri Apr 01, 2016 7:14 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Well I test fit my 30s.
The rears went on with no problems at all and no lift and man does it make that wheel well look more full!

The fronts go on and don't touch when straight (no more than 3/16" clearance at the rear of the fender, my warped mud guard thing touches) but any turning of the wheel and they hit the fender almost right away, and a little bit on the front inner wheel well in a not visible area. Also no lift or torsion bar crank. The fender will need a bit of trimming but not that bad. Not going to go farther than it needs to clear with the suspension loaded and wheel turned.

Left the 30s on the back to test out the ratio and it is a lot better! 55 is around 2150 rpm vs 2600 before and 70 at about 3000. between the 30s and the 5th gear I have gained 15mph at 3000rpm over stock. If i get myself a 3.73 rear gear it will be about perfect

Thinking I am gonna try to use my cut off wheel and take a wedge out of the fender and reweld the edge back on to keep it rigid and avoid the "cut fender" look so many cherokees have. It doesn't need as much as I expected I will post up some pics of the before and after and what gets cut from the fender

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 06, 2016 2:40 pm 
Offline
lives at LUVTruck.com

Joined: Mon Feb 24, 2014 11:19 am
Posts: 269
Location: Lodi CA
Did you snap any pictures of the 30s on your truck?


Top
 Profile  
Reply with quote  
PostPosted: Wed Apr 06, 2016 6:59 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Haven't yet still need to get around to putting them on the front, too many projects. They work out well on the back, much more grip

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Thu Apr 14, 2016 5:29 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
here is it with them on the rear.

Image

don't hang out of the wheel well

Image

my work tools, truck battery, the other 2 30s and the other 2 195/75r14s are in the bed. had two friends on the bumper jumpin around still clears
Image

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Sun Jun 12, 2016 4:06 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Finally got my running issue fixed
Distributor hitting the firewall before i reclocked it knocked the connector for the 12v+ wire loose inside the coil cover. Took it apart soldered new ends on the wire i ran and connected the wire with the cap off so i could keep it from pushing up.
Runs like a champ pulls solidly to 5000 where i call it good. Only thing it does is stumble a couple times if i try to go from 0-1/8 throttle to wot quickly, and that should be either acc pump or transfer port size related, and a bit to do with a mech secondary probably
Gonna be looking for a slow day at the mopar shop to go dyno it

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Sun Jun 12, 2016 8:45 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Did some test fitting of the 30" front tires.
They definitely wont go on with 0" lift without some metal work. Went to full steering lock both ways lowered it down until it touched and took measurements on travel left to go and got a good idea of what it needs.
So looks like next weekend may involve some cutting and welding.
The front of the inner fender needs the inside corner taken off
The back of the outer fender needs to be trimmed back... Less than i see a lot of jeeps. But still a good bit
And the firewall right where the stock rounded part meets the flatter floor bend, needs to carry the curve a bit more. I made marks of all the spots that need attention.
Will take pics when i get it done.
Determined to make them fit and clear, i want the 30s but not a bunch of lift to raise my COG even more than adding over 5 inches of tire already does.

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Tue Sep 20, 2016 8:11 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Will have a new distributor thursday. The old one finally decided to start completely dropping ignition and jumping timing all over so it would be spinning dead then backfire like hell when it caught again and have no power and misfire constantly. No fun trying to limp it home.

Hoping to get to the dyno and the track once it is finally fixed. I took way too long to order a new one.

Edit: will be here tomorrow. Gotta love when a carrier beats their own arrival schedule

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Sat Oct 01, 2016 5:40 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
Finally got it figured out... Long time later..
Got the new distributor in. Solved the cutting out and misfire issue with a little tinkering
Problem is being an ebay hei it had a cheap@$$ adjustable vac canister on it that didnt adjust. The internal screw was trashed out of the box... Ebay quality, go figure. Has a lifetime warranty but it isnt worth the return shipping for a 15 dollar vac canister.
It was throwing all the advance in as soon as i cracked the throttle.. Was really bad sitting still it basically just went silent and sputtered when i opened it a bit. Backing out of a parking space it backfired and died. Swapped to the old vac canister. Same thing all advance at 1/8- throttle.
Disconnected the vac line and it runs fantastic. Has less overall advance with only the mechanical advance but it runs absolutely smooth no misfire no bs. So next step is buying a quality vac canister or gping full mechanical and getting it dialed before finally getting it on the dyno

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
PostPosted: Thu Oct 12, 2017 10:25 pm 
Offline
lives at LUVTruck.com
User avatar

Joined: Mon Aug 21, 2006 7:10 pm
Posts: 383
Location: Vancouver, Washington
love4theluv wrote:
Finally got it figured out... Long time later..
Got the new distributor in. Solved the cutting out and misfire issue with a little tinkering
Problem is being an ebay hei it had a cheap@$$ adjustable vac canister on it that didnt adjust. The internal screw was trashed out of the box... Ebay quality, go figure. Has a lifetime warranty but it isnt worth the return shipping for a 15 dollar vac canister.
It was throwing all the advance in as soon as i cracked the throttle.. Was really bad sitting still it basically just went silent and sputtered when i opened it a bit. Backing out of a parking space it backfired and died. Swapped to the old vac canister. Same thing all advance at 1/8- throttle.
Disconnected the vac line and it runs fantastic. Has less overall advance with only the mechanical advance but it runs absolutely smooth no misfire no bs. So next step is buying a quality vac canister or gping full mechanical and getting it dialed before finally getting it on the dyno



I'm having the same issue where I give a little throttle and it sputters and dies out. I adjusted the timing on it and it seems to be good now, but I need to rebuild this damn carb!

_________________
Image


Top
 Profile  
Reply with quote  
PostPosted: Sat Oct 28, 2017 7:09 pm 
Offline
Addicted to LUV
User avatar

Joined: Thu Jan 21, 2010 11:47 pm
Posts: 2856
Location: Vancouver, Washington
SkyyPayne wrote:
love4theluv wrote:
Finally got it figured out... Long time later..
Got the new distributor in. Solved the cutting out and misfire issue with a little tinkering
Problem is being an ebay hei it had a cheap@$$ adjustable vac canister on it that didnt adjust. The internal screw was trashed out of the box... Ebay quality, go figure. Has a lifetime warranty but it isnt worth the return shipping for a 15 dollar vac canister.
It was throwing all the advance in as soon as i cracked the throttle.. Was really bad sitting still it basically just went silent and sputtered when i opened it a bit. Backing out of a parking space it backfired and died. Swapped to the old vac canister. Same thing all advance at 1/8- throttle.
Disconnected the vac line and it runs fantastic. Has less overall advance with only the mechanical advance but it runs absolutely smooth no misfire no bs. So next step is buying a quality vac canister or gping full mechanical and getting it dialed before finally getting it on the dyno



I'm having the same issue where I give a little throttle and it sputters and dies out. I adjusted the timing on it and it seems to be good now, but I need to rebuild this damn carb!

Hey Chris long time no see man! I just sent u a message earlier today not realizing u had replied here. Glad to hear you still have your LUV.
Have you tried tuning your carb with a vacuum gauge yet?
My new carb is being a hassle. Sold my Edelbrock 500 and got a vac secondary Holley 450 but I can't get it to idle down. Won't go under 1400rpm at all and will randomly gain rpm on it's own. Seems like a vac leak or something but there really aren't many places for there to be a leak there is only 1 vac tube! My timed vac port has vacuum at that rpm so I need to sort out what's happening. I got a new set of gaskets etc when I bought it and did all the bench settings.

_________________
1980 Mikado, Chevy 4.3 V6. Compcams 270HR, edelbrock intake and carb, vortec heads, s10 NV3500, stock 4.10 rear. The toy
1999 Isuzu Rodeo 4x4, 31" kumho mt's, the wife's daily driver
1993 Lexus SC400 my DD


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 555 posts ]  Go to page Previous  1 ... 24, 25, 26, 27, 28

All times are UTC - 6 hours


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group