LUVTruck.com

phpBBV3 Message Board
It is currently Thu Apr 26, 2018 1:48 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Dec 24, 2013 2:04 pm 
Offline
Junior Member

Joined: Tue Oct 31, 2006 6:06 am
Posts: 6
So I have an 82 diesel luv. Currently it won't start. I have no power to the dash for gauges or idiot lights. Headlights also not working. I did figure out that the fuel cut off switch on the pump isn't receiving power. It will crank fine, just won't start. I've verified both fusible links right off battery. Haven't verified alternator or voltage regulator. Any ideas? I'm about ready to give up on it.


Top
 Profile  
Reply with quote  
PostPosted: Tue Dec 24, 2013 2:35 pm 
Offline
Addicted to LUV
User avatar

Joined: Tue Sep 13, 2005 7:54 am
Posts: 1481
Location: Germantown, TN (right next to ElvisTown)
I'm going to reply to your earlier post at IsuzuPup.com. Well, they're both at the same time and identical, but it's the one I saw first.

Jack

_________________
'83 Isuzu P'up Diesel LS - Original Owner
JoeIsuzu@IsuzuPup.com
IsuzuPup.com


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group