LUVTruck.com

phpBBV3 Message Board
It is currently Sun Dec 16, 2018 5:50 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Mon Aug 29, 2011 4:57 pm 
Offline
LUVTruck.com Regular
User avatar

Joined: Wed Aug 10, 2011 2:00 pm
Posts: 118
in the last 2 weeks but so far on the chevy luv we have done

fuel filter,

cap ,

rotor,

points

condenser.

19 ft of vacuum hoses new ignition wires

spark plugs

have used sea foam engine treatment in carb,vacuum lines,gas tank

tranny fluid exchange

radiator thermostat

radiator thermostat gasket

radiator flush

engine degreased

exhaust flange gasket

repaired exhaust leak

valve cover gasket

exhaust manifold gasket

intake manifold gasket

oil stll leaking (to do list)added 2 quarts of oil

some hoses replaced with heater hose
cleaned electrical connections, fuse box too

new fuel pump (original one faulty now)

carb rebuilt kit

carb to manifold gasket replaced

compression test

new MSD ignition coil

vacuum testing

timing

fuel pump relay switch

fixed the horn- contact ring on steering wheel was dirty

low/high beam switch fixed- low beam lights again yay!

theres probably more but the heat has gotten to my brain

_________________
What part is this?
What is it for?
How Do I test it?
Where do i get a new one?
Are we there yet??


Top
 Profile  
Reply with quote  
PostPosted: Mon Aug 29, 2011 8:44 pm 
Offline
Addicted to LUV

Joined: Mon Aug 28, 2006 11:54 pm
Posts: 6484
Location: Pelahatchie, MS
So, is it running now?

_________________
If you think no one cares, try missing a couple of payments...



FIAA!

SFPP!


Top
 Profile  
Reply with quote  
PostPosted: Mon Aug 29, 2011 9:20 pm 
Offline
LUVTruck.com Regular
User avatar

Joined: Wed Aug 10, 2011 2:00 pm
Posts: 118
mytmouz wrote:
So, is it running now?

well............. for 10 seconds then dies lol. the fuel pump and carb kit will be here in a few days. we will put the fuel pump in first, before we touch the carb. we have been doing one thing (so we can tell if there was a problem) at a time. if its not the fuel pump it could be the ignition switch thats giving an intermittent signal on one of the prongs (according to the ohms meter). it was just neglected with upkeep prior to me. just had very low upkeep maintenance done.plus everything in it was still basically originally put there 30 years ago.-- except the belts of course
but it was running - just like crap.. before we did the intake manifold we had it running good and quiet. good as in it didnt have giddy up and go just like 0-60 .......eventually (3 fwy exits to get to 60 )

_________________
What part is this?
What is it for?
How Do I test it?
Where do i get a new one?
Are we there yet??


Top
 Profile  
Reply with quote  
PostPosted: Mon Aug 29, 2011 9:26 pm 
Offline
Addicted to LUV
User avatar

Joined: Fri Jul 01, 2005 9:41 pm
Posts: 6199
Location: Camarillo, CA
Try running 12 volts straight to the fuel pump so you dont keep throwing money at it, that will tell you if its electrical or not.

_________________
Certified pilots, looking down on people since 1903.


Top
 Profile  
Reply with quote  
PostPosted: Mon Aug 29, 2011 9:50 pm 
Offline
LUVTruck.com Regular
User avatar

Joined: Wed Aug 10, 2011 2:00 pm
Posts: 118
Luvrv8 wrote:
Try running 12 volts straight to the fuel pump so you dont keep throwing money at it, that will tell you if its electrical or not.

we did that though, we held the wires on the battery and it was pumping. how much pumping pressure is unknown if ok or weak as we have no way to test the output pressure. just was pumping squirting gas -what was left in the pump everywhere. we opened it up and cleaned it too. but when we put it back sometimes it worked mostly not. the carb inlet jets where the fuel screen is abouve the needle and float was caked heavy. cleaned that. we called everywhere to see if anyone could test it for us but i was told only if its on the car- meaning they want to charge me shop fees and labor. the relay was changed its not that-. my dad only gave the truck light maintenance- never needed it much so mainly he just drove it 5 miles a week for a long time. but its 30 years old and electrical goes to crap the ohms meter has a scratchy broken tone from one to another prongs for signal on the ignition cylinder and the new fuse box will be here in a few days to change that out. the original was corroded and the regulator port on it is broken on one of the metal tabs. which explains the strange heat light- no dash lights- and the gen light the box had just been disturbed to clean it the same time an intake manifold.

_________________
What part is this?
What is it for?
How Do I test it?
Where do i get a new one?
Are we there yet??


Top
 Profile  
Reply with quote  
PostPosted: Mon Aug 29, 2011 10:22 pm 
Offline
Addicted to LUV
User avatar

Joined: Fri Jul 01, 2005 9:41 pm
Posts: 6199
Location: Camarillo, CA
Run the 12 volts to it while its on the truck to see if it runs longer then 10 seconds.

_________________
Certified pilots, looking down on people since 1903.


Top
 Profile  
Reply with quote  
PostPosted: Mon Aug 29, 2011 10:56 pm 
Offline
LUVTruck.com Regular
User avatar

Joined: Wed Aug 10, 2011 2:00 pm
Posts: 118
Luvrv8 wrote:
Run the 12 volts to it while its on the truck to see if it runs longer then 10 seconds.


thanks luvrv8 - he did test it that way too when i told him your advice. he said it did work but since its ordered and the one on the truck is 30 yrs old hes replacing it anyways at this point. he says the fuse box has problems- (new one already on the way) the ignition switch is faulty (new one already on the way) i so appreciate the advice and help. i pass it on to him as i get info- unless he sees it first. he is just making trying to avoid having to turn around and wonder if things are still working good, and if they are new it narrows out what it isnt so to speak. we were blessed with a sum of financial help from my dad to help. theres an electrical nightmare with connections hes fixing as well. he is surprised there hasnt been a fire.. basically

_________________
What part is this?
What is it for?
How Do I test it?
Where do i get a new one?
Are we there yet??


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group