LUVTruck.com

phpBBV3 Message Board
It is currently Mon Dec 11, 2017 3:01 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Mon Jan 25, 2016 7:45 pm 
Offline
Addicted to LUV

Joined: Sun Jun 06, 2004 11:48 pm
Posts: 6138
Location: Whittier, (So). Cal.
So I bought this..http://www.ebay.com/itm/291641799742?_t ... EBIDX%3AIT
Put them in yesterday. Super easy install and all went well. But when I turn the wheel, I get a rubber on metal sounding squeak out of both sides, the right worse than the left. Where did I go wrong? Is there a secret trick I missed?
Oh, this is on my 1998 Ford Windstar mini van. Don't be jealous, you can can by one for yourself too. :lol:

_________________
3M TA3


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 25, 2016 7:51 pm 
Offline
Addicted to LUV
User avatar

Joined: Fri Jul 01, 2005 9:41 pm
Posts: 6129
Location: Camarillo, CA
I would guess the noise you hear is from the top mounts. When I was at the dealer that was usually what made the noise.

_________________
Certified pilots, looking down on people since 1903.


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 25, 2016 7:56 pm 
Offline
Addicted to LUV

Joined: Sun Jun 06, 2004 11:48 pm
Posts: 6138
Location: Whittier, (So). Cal.
That's where it sounds like it's coming from. That's where the, what they call, the bearing is. The assembly turned by hand nicely before I put the hub assembly on. but all done and on the ground and I have this squeak. :econfused WD40???

_________________
3M TA3


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 25, 2016 8:18 pm 
Offline
Addicted to LUV
User avatar

Joined: Fri Jul 01, 2005 9:41 pm
Posts: 6129
Location: Camarillo, CA
You can try WD40. My experience has been the rubber squeaks where the bearing is.

_________________
Certified pilots, looking down on people since 1903.


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 25, 2016 8:25 pm 
Offline
Addicted to LUV

Joined: Sun Jun 06, 2004 11:48 pm
Posts: 6138
Location: Whittier, (So). Cal.
OK thanks, I'll drive it a few days and see what it does. I may have to dig into it again this weekend.
It does ride much nicer with the new ones though. 8)

_________________
3M TA3


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group